Trading: Nuri Pots
Incident Report for Nuri
Resolved
This incident has been resolved.
Posted Jul 06, 2022 - 08:18 CEST
Investigating
We are currently experiencing issues with the Nuri pots. Our banking partner is working with a high priority on a fix.

Derzeit kommt es zu Problemen bei den Nuri Pots. Unser Bankpartner arbeitet mit hoher Priorität an einer Lösung.
Posted Jul 05, 2022 - 11:34 CEST
This incident affected: Trading.