Trading: Settlement of BTC / ETH trades
Incident Report for Nuri
Resolved
This incident has been resolved.

Der Incident wurde behoben.
Posted May 04, 2022 - 18:04 CEST
Investigating
We are currently experiencing delays in the settlement of BTC and ETH. We are working with a high priority on a fix.

Derzeit kommt es zu Verzögerungen bei der Abrechnung von BTC- und ETH-Trades oder -Transfers. Wir arbeiten mit hoher Priorität an einer Lösung.
Posted May 04, 2022 - 11:24 CEST
This incident affected: Trading.